miércoles, 1 de junio de 2011

Habilitar o activar el protocolo SSL en XAMPP


 











Cuando instalamos XAMPP, por defecto trae deshabilitado el protocolo de seguridad SSL. Puede que necesitemos utilizar este protocolo en nuestras aplicaciones, por ejemplo, para enviar un correo electrónico. Por tanto, vamos a describir en unos pocos pasos lo que debemos hacer para activarlo.


Pasos a seguir:


     1. Parar el servicio Apache, si es que lo tenemos levantado (desde el panel de control de XAMPP pulsamos el botón STOP de Apache). 

     2. Copiar los archivos libeay32.dll y ssleay32.dll de la carpeta xampp\php\ en la carpeta xampp\apache\bin\ , sobreescribiendo los existentes.

     3. Editar el fichero php.ini que está en uno de estos directorios:  xampp\apache\bin o xampp\php . 
       
     Tenemos que buscar y descomentar (quitarle el ";") la siguiente línea
     ;extension=php_openssl.dll  
    

     En caso de que no aparezca esa línea en php.ini, simplemente añadimos  lo  siguiente al final del archivo: 
extension=php_openssl.dll 

     4. Levantar el servicio Apache (desde el panel de control de XAMPP pulsamos el botón START de Apache).



Con esto sería suficiente para que tengamos disponible el protocolo SSH en todas las aplicaciones que ejecutemos sobre XAMPP. 


Espero que os ayude, si encotrais cualquier problema, podeis utilizar los comentarios.


Fuente:

 

http://www.leoganda.net/how-to-enable-xampp-ssl-socket-transport/






22 Comentarios:

musicafm.tk dijo...

Graciassssss me ha servido

Felipe dijo...

Gracias a tí por comentar.

Saludos.

Mosiah dijo...

Muchas gracias por la información.

Saludos.

Felipe dijo...

Hola Mosiah.

Muchas gracias por comentar.

Saludos.

SkaRootz dijo...

Muchas Gracias, pero me pregunto por que los de xampp no dejan mas simple lo de activar el openssl???

Felipe dijo...

Hola SkaRootz,

Es cierto que podrían poner una opción desde el panel de control de XAMPP para activar el SSL, pero desconozco por qué no lo han hecho.

Gracias por comentar.

Saludos.

Simón dijo...

He probado varias veces a hacerlo (instalando y desinstalando el Xampp) y cuando acabo no se arranca el Apache al darle a Start y si pongo localhost en el navegador no me encuentra la página.

Felipe dijo...

Hola Simón.

Para que te pueda ayudar, puedes enviarme una captura de pantalla (a mi correo) de la aplicación Xampp para localizar el error. También indícame el contenido del fichero log de Xampp, que es “error.log” y debería estar en la carpeta “xampp\apache\logs”.

Con esos datos creo que podré indicarte qué es lo que ocurre.

Saludos.

Simon dijo...

Hola Felipe.

Muchas gracias por responder. Te he enviado por correo los dos archivos.

Un saludo y muchas gracias de nuevo.

Felipe dijo...

Hola Simón.

He respondido a tu correo.

Saludos.

Gerson dijo...

esto funciona tambien en windows?

Gerson dijo...

o solo es para linux?

Felipe dijo...

Hola Gerson.

Funciona tanto para windows como para linux. El paso 2 si estás en Linux puedes saltártelo.

Si tienes alguna duda, dímelo.

Saludos.

miguel dijo...

hola!! no se si alguna vez has usado OSC inventory(para hacer inventario de equipos a travez de la red) tengo asignado enviar paquetes desde mi servidor a los clientes, al momento de hacer esto, me sale deshabilitado el servidor para poder cargar archivos, pues lei y me pedia habilitar SSL, pensaba que sería suficiente, hice todo lo que explicas aca, vi el estado del XAMPP on seguridad, pero el prolema persiste..(no puedo cargar archivos), quizas tengas conocimiento sobre esto si no molestia, aca cuenta google. gracias por la info ;)

Felipe dijo...

Hola Miguel.

No he utilizado la aplicación que me comentas. Si has seguido los pasos de este artículo, el protocolo SSL estará activado. Por lo que intuyo que la causa puede ser otra. No obstante, si alguien sabe como solucionarlo, lo puede indicar en los comentarios.

Saludos.

Matías dijo...

Hola. Realicé todos los pasos pero no me inicia Apache luego de pisar los archivos.

El log dice lo siguiente:

[Fri Feb 01 11:57:02.958593 2013] [core:warn] [pid 4816:tid 228] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Feb 01 11:57:03.414619 2013] [ssl:warn] [pid 4816:tid 228] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Feb 01 11:57:04.041655 2013] [mpm_winnt:notice] [pid 4816:tid 228] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Fri Feb 01 11:57:04.041655 2013] [mpm_winnt:notice] [pid 4816:tid 228] AH00456: Server built: Aug 18 2012 12:41:37
[Fri Feb 01 11:57:04.041655 2013] [core:notice] [pid 4816:tid 228] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Feb 01 11:57:04.052656 2013] [mpm_winnt:notice] [pid 4816:tid 228] AH00418: Parent: Created child process 5052
[Fri Feb 01 11:57:05.796755 2013] [ssl:warn] [pid 5052:tid 240] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Feb 01 11:57:05.857759 2013] [mpm_winnt:notice] [pid 5052:tid 240] AH00354: Child: Starting 150 worker threads.

Felipe dijo...

Hola Matías.

¿En qué sistema operativo estás trabajando?. He encontrado una solución a tu problema en Windows: http://suhancoold.blogspot.com.es/2010/02/apache-server-wont-start-httpdpid.html .


Se trata de desinstalar Apache, eliminar el directorio de Apache y volver a instalarlo.

Si ésto no soluciona tu problema, avísame y buscamos otra solución.

Saludos.

Anónimo dijo...

hola te mande un correo, con el error que me marco, nose si me podrias apoyar porfavor

Felipe Martínez D. dijo...

Hola.

He contestado a tu correo.

Saludos.

Óscar Rodríguez dijo...

Gracias fue de gran Ayuda.

xplicando.blogspot.com

Anónimo dijo...

Hola, quisiera habilitar un servicio web para que se pueda ver por https. es decir: invocarlo como https://localhost:443/WebService/services/Consulta?wsdl, ya tengo habilitado el SSL. ¿Como puedo hacerlo?

Muchas Gracias!

Felipe Martínez D. dijo...

Hola.

@Óscar Rodríguez: Me alegro de que te sirviera.

@Anónimo: Para poder ayudarte deberías de darme más datos de en qué consiste y como estás ejecutando tu Web Service. Por lo pronto encontré este artículo http://wiki.gxtechnical.com/commwiki/servlet/hwiki?Consumir+servicios+web+bajo+https+y%2Fo+autenticaci%C3%B3n, en el que se explica como hacer uso de web services bajo https.

Saludos a los dos.

Publicar un comentario

Felinfo: Java, Linux, Virtualización. Open Source.  ©Template Blogger Green by Dicas Blogger .

TOPO